HD コール(VoIP:Voice over Internet Protocol)を使用すると、発着信の通話は携帯キャリアの音声ネットワーク経由ではなく、インターネット経由で行われます。
以下、詳細をご参照ください。
HD コールを利用するメリット
HD コールを有効にすることで、ビジネスコミュニケーションにおいて以下のような多くのメリットが得られます。
コストの削減: 携帯キャリアの通話料金や契約プランの通話時間を節約できます。
Wi-Fi 通話: モバイル音声ネットワークの電波が弱い環境でも、Wi-Fi を経由して通話が可能です。
国際通話の無料化:Dialpad ユーザー間の国際通話を無料でご利用いただけます。
高度な通話機能の利用: 保留、転送、通話録音などの便利な通話中機能にアクセスできます。
HD コールの設定方法
発着信の通話に対して、HD コールのオン/オフ(有効/無効)を任意に切り替えることができます。
デバイスで Dialpad アプリ を起動し、アプリ左上のプロフィールをタップします。
[通話設定] > [通話体験] を選択します。
[HD コール] をオンにします。

HD コールとキャリアコールの切り替え
3G ネットワークに接続している場合や、モバイルデータ通信の使用量を抑えたい場合は、通話を携帯キャリアに切り替えます。
iOSの場合:
通話中に、[その他] メニュー(3つのドット)を選択します。
[キャリアコールに切り替え] を選択します。

Android の場合:
通話中に、[モバイルに切り替え] を選択します。
Note
別途キャリアとの契約が必要です。
HD 通話中に Wi-Fi の範囲外に移動する場合
4G 以上のモバイルネットワークに接続されている限り、Dialpad は自動的に通話をモバイルデータ通信に切り替えるため、何も行う必要はありません。
iPhone で HD コールに応答しようとすると通話拒否になることがあります。本記事では対処法をご案内します。
問題
iPhone の Dialpad アプリに着信があり、応答ボタンをタップした直後にすぐに切断されてしまいます。応答ボタンをタップした後の画面には次のように表示されます。回避するにはどうしたらよいでしょうか?
Dialpad 00:00
Dialpad 通信拒否

どのような場合に発生するのか?
下記のすべての条件を満たす場合に発生することが確認されています:
[個人設定] > [デバイス] にキャリアの番号が認識されており、[このデバイスを鳴らす] にチェックが入っています。

iPhone アプリにログインする際にキャリア番号の入力をスキップしています。

Note
管理者が HD コールを強制している場合は、iPhone アプリにログインする際にキャリア番号の入力画面は表示されません。
原因
これはサーバーが、アプリとキャリア番号が同じデバイスを使っていることを判別できないことに起因します。
何が起こっているのか?
PSTN (キャリア) と VoIP (HD コール) の両方のコールを同じデバイスで着信したときに、アプリが両方のコールに対して呼び出して競合状態になります。多くの場合、PSTN への着信が先行する傾向があります。応答ボタンをタップした後の画面が次のように表示されるのはこのためです。
Dialpad 00:00 <-- PSTN に着信
Dialpad 通信拒否 <-- VoIP に着信
ユーザーが応答ボタンをタップすると、Dialpad テレフォニーシステムはユーザーが2つの着信のうちいずれか一方を切断したと認識し、同時に iPhone 側でも片方の着信が切断されます。ユーザーが不在着信のルーティングをボイスメールに設定している場合は、片方の着信が切断されると Dialpad のボイスメールにつながります。
まれに応答ボタンを押してから数秒間通話が可能となるケースがあります。しかしこの場合でも Dialpadの通話システムからから 切断(Hangout) シグナルが送信されると同時に通話が自動的に切断されます。
なお、これはアプリケーションのバグではなく、上記のような挙動に対して OS の仕様が対応していないことに起因します。
回避方法
キャリア番号を Dialpad アカウントに認識させたい場合
iPhone アプリにログインする際にキャリア番号の入力をスキップしないでください。
ログイン時にスキップした場合は、iPhone アプリ > [設定画面] > [その他設定] からキャリア番号を入力してください。
キャリア番号への転送が不要な場合
[個人設定] > [デバイス] から転送番号を削除するか、転送番号の [このデバイスを鳴らす] のチェックを外してください。
その後 iPhone の Dialpad アプリからログアウトしてください。
上記の手順で事象が改善されない場合は、iPhone から Dialpad アプリを削除して、再度インストールしてください。アプリを削除することで、転送番号とアプリの関連付が解除されます。
Note
転送番号を [個人設定] > [デバイス] から削除しても、iPhone のアプリにログインする際にキャリア番号の入力を求められず自動的にスキップするときがあります。これは一度でもアプリとキャリア番号の紐付けが認識されると、 デバイスページから転送番号を削除しただけでは Dialpad アカウントとの紐付けが完全に解除されていないことが原因です。アプリを削除して(デバイスページからも転送番号を削除しておき)再インストールしてからログインすると、キャリア番号の入力が求められるようになります。
管理者が HD コール強制を設定している場合
上記1→3の手順と同様