iPhone で HD コールに応答しようとすると通話拒否になることがあります。本記事では対処法をご案内します。
問題
iPhone の Dialpad アプリに着信があり、応答ボタンをタップした直後にすぐに切断されてしまいます。応答ボタンをタップした後の画面には次のように表示されます。回避するにはどうしたらよいでしょうか?
Dialpad 00:00
Dialpad 通信拒否
どのような場合に発生するのか?
下記のすべての条件を満たす場合に発生することが確認されています:
[個人設定] > [デバイス] にキャリアの番号が認識されており、[このデバイスを鳴らす] にチェックが入っている
iPhone アプリにログインする際にキャリア番号の入力をスキップしている
Note
管理者が HD コールを強制している場合は、iPhone アプリにログインする際にキャリア番号の入力画面は表示されません。
回避方法の管理者が HD コール強制を設定している場合をお読みください。
原因
これはサーバーが、アプリとキャリア番号が同じデバイスを使っていることを判別できないことに起因します。
何が起こっているのか?
PSTN (キャリア) と VoIP (HD コール) の両方のコールを同じデバイスで着信したときに、アプリが両方のコールに対して呼び出して競合状態になります。おおかた PSTN の方が早い傾向があります。応答ボタンをタップした後の画面が次のように表示されるのはこのためです。
Dialpad 00:00 <-- PSTN に着信
Dialpad 通信拒否 <-- VoIP に着信
ユーザーが応答ボタンをタップすると、Dialpad テレフォニーシステムはユーザーが2つの着信のうちどちらか一方を Drop したと認識して、同時に iPhone も片方の着信を Drop します。ユーザーが不在着信のルーティングをボイスメールに設定している場合は、片方の着信が Drop されると Dialpad のボイスメールにつながります。
まれに応答ボタンを押してから数秒間通話可能なケースがあるかもしれません。しかしこの場合でもDialpad テレフォニーシステムから hangout シグナルが送られると同時に通話が自動的に切断されます。
しかしながらこれはバグではなく、上記のシナリオに対応するように OS がデザインされていないことを意味します。
回避方法
キャリア番号を Dialpad アカウントに認識させたい場合
iOS アプリで初回のログイン時に、キャリア番号の入力をスキップしないでください。
ログイン時にスキップした場合は、iOS アプリ左上のプロフィールアイコンをタップ > [設定] > [その他の設定] よりキャリア番号を入力してください。
Note
管理者が HD コールを強制している場合は、iPhone アプリにログインする際にキャリア番号の入力画面は表示されません。
回避方法の管理者が HD コール強制を設定している場合をお読みください。
原因
キャリア番号への転送が不要な場合
[個人設定] > [デバイス] から転送番号を削除するか、転送番号の [このデバイスを鳴らす] のチェックを外してください。
その後 iPhone の Diapad アプリからログアウトしてください。
1→2の手順で改善されない場合は、iPhone から Dialpad アプリを削除して、再度インストールしてください。アプリを削除することで、転送番号とアプリの関連付が解除されます。
Note
転送番号を [個人設定] > [デバイス] から削除しても、iPhone のアプリにログインする際にキャリア番号の入力を求められず自動的にスキップするときがあります。これは一度でもアプリとキャリア番号の紐付けが認識されると、 デバイスページから転送番号を削除しただけでは Dialpad アカウントとの紐付けが完全に解除されていないことが原因です。アプリを削除して(デバイスページからも転送番号を削除しておき)再インストールしてからログインすると、キャリア番号の入力が求められるようになります。
管理者が HD コール強制を設定している場合
上記1→3の手順と同様